Documenting Problems That Were Difficult To Find The Answer To

Building libtorrent-rasterbar with Boost not detected error

So you’re using Debian Wheezy or Ubuntu Lucid and you get the following error:

checking for boostlib >= 1.36... configure: We could not detect the boost libraries (version 1.36 or higher). If you have a staged boost library (still not installed) please specify $BOOST_ROOT in your environment and do not give a PATH to --with-boost option.  If you are sure you have boost installed, then check your version number looking in . See for more documentation.
checking whether the Boost::System library is available... no

You know you’ve got the Boost libraries of version 1.40 or so installed. So what’s going on? The clue is in config.log:

cc1plus: error: unrecognized command line option "-ftemplate-depth=120"

The fix? Edit your configure file and comment out the line:

#CXXFLAGS="$CXXFLAGS -ftemplate-depth=120"

… and re-configure. This issue was discovered with libtorrent-rasterbar-0.16.19.

Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: